Man page for apt-get rpcbind Command
This tutorial shows the man page for man rpcbind in linux.
Open terminal with 'su' access and type the command as shown below:
Result of the Command Execution shown below:
RPCBIND(8) BSD System Manager's Manual RPCBIND(8)
rpcbind universal addresses to RPC program number mapper
rpcbind [ adhiLls]
The rpcbind utility is a server that converts RPC program numbers into
universal addresses. It must be running on the host to be able to make
RPC calls on a server on that machine.
When an RPC service is started, it tells rpcbind the address at which it
is listening, and the RPC program numbers it is prepared to serve. When
a client wishes to make an RPC call to a given program number, it first
contacts rpcbind on the server machine to determine the address where RPC
requests should be sent.
The rpcbind utility should be started before any other RPC service. Nor
mally, standard RPC servers are started by port monitors, so rpcbind must
be started before port monitors are invoked.
When rpcbind is started, it checks that certain name to address transla
tion calls function correctly. If they fail, the network configuration
databases may be corrupt. Since RPC services cannot function correctly
in this situation, rpcbind reports the condition and terminates.
The rpcbind utility can only be started by the super user.
a When debugging ( d), do an abort on errors.
d Run in debug mode. In this mode, rpcbind will not fork when it
starts, will print additional information during operation, and
will abort on certain errors if a is also specified. With this
option, the name to address translation consistency checks are
shown in detail.
h Specify specific IP addresses to bind to for UDP requests. This
option may be specified multiple times and is typically necessary
when running on a multi homed host. If no h option is speci
fied, rpcbind will bind to INADDR_ANY, which could lead to prob
lems on a multi homed host due to rpcbind returning a UDP packet
from a different IP address than it was sent to. Note that when
specifying IP addresses with h, rpcbind will automatically add
127.0.0.1 and if IPv6 is enabled, ::1 to the list.
i ``Insecure'' mode. Allow calls to SET and UNSET from any host.
Normally rpcbind accepts these requests only from the loopback
interface for security reasons. This change is necessary for
programs that were compiled with earlier versions of the rpc
library and do not make those requests using the loopback inter
l Turn on libwrap connection logging.
s Cause rpcbind to change to the user daemon as soon as possible.
This causes rpcbind to use non privileged ports for outgoing con
nections, preventing non privileged clients from using rpcbind to
connect to services from a privileged port.
w Cause rpcbind to do a "warm start" by read a state file when
rpcbind starts up. The state file is created when rpcbind termi
All RPC servers must be restarted if rpcbind is restarted.
BSD September 14, 1992 BSD